From: Glenn Parker Date: 2005-02-10T22:41:08+09:00 Subject: Re: Building a Better Functor Robert Klemme wrote: > class << self;self;end.class_eval do This particular trick has shown up a lot on the Ruby list lately. It's kind of ugly, but clearly useful. I think it deserves a name, or possibly a new keyword. What would you call it, "virtual_class_eval"? -- Glenn Parker | glenn.parker-AT-comcast.net |