From: gabriele renzi Date: 2005-01-29T07:45:51+09:00 Subject: Re: Convert a Hash into an Array linus sellberg ha scritto: > georgesawyer wrote: > >>> did I mention that I love #inject? :-) >> >> (Wistfully) Even though 'inject' is the name in Smalltalk, I feel it were >> better named, 'consolidate'. > > > I don't have anything against #inject, but I could see the case for an > alias #accumulate, much like SICP's accumulate which afaik is the same > thing. > > (I wouldn't mind #reduce as well, though that would be slightly incorrect) #fold would be better imho (even if slightly incorrect)