From: "David A. Black" Date: 2005-01-25T23:10:51+09:00 Subject: Re: attr Hi -- On Mon, 24 Jan 2005, Trans wrote: >> I like the features you've added, though. >> Could you perhaps call it something other than >> "attr", to avoid breakage? > > I suppose, but first let me explain. It used to be called #def_attr for > the reason you state. But I always felt like I might as well use #attr > due to its _relative_ uselessness (i.e. overlap functionality with much > more commonly used methods). So I posted a topic here on this list > (110245) that asked about it, and the jist seemed to be that it was > pretty much abandoned. Also, keep in mind that programs using the old > #attr won't be effected unless they become a part of something that > requires this lib --and hell, the current definition of #attr almost > seems like a bug anyway; maybe poeple be happy to finally root them > out. Further, it is backward compatible with reader notation; just not > the accessor notation (i.e. 'attr :a, true'). laptop:/usr/local/lib/ruby/1.8$ ruby -ne 'print $_ if /^\s+attr\s/' `find . -name "*.rb"` | wc 76 217 1902 I think some of the ideas you're suggesting might have some interest but I definitely wouldn't include a module that redefined attr in an incompatible way. David -- David A. Black dblack@wobblini.net