From: Trans Date: 2005-01-24T23:40:51+09:00 Subject: Re: attr > I like the features you've added, though. > Could you perhaps call it something other than > "attr", to avoid breakage? I suppose, but first let me explain. It used to be called #def_attr for the reason you state. But I always felt like I might as well use #attr due to its _relative_ uselessness (i.e. overlap functionality with much more commonly used methods). So I posted a topic here on this list (110245) that asked about it, and the jist seemed to be that it was pretty much abandoned. Also, keep in mind that programs using the old #attr won't be effected unless they become a part of something that requires this lib --and hell, the current definition of #attr almost seems like a bug anyway; maybe poeple be happy to finally root them out. Further, it is backward compatible with reader notation; just not the accessor notation (i.e. 'attr :a, true'). Oh I forgot a question too. Sould 'attr :a=' create just a writer, like I have it, or should it instead create a reader and a writer, since writers are very uncommon? (Though in that case I don't know what notation to use for just writer.) -T.