From: ts Date: 2005-01-13T19:36:10+09:00 Subject: Re: Kernel#eval and class definition >>>>> "R" == Robert Klemme writes: R> That's better because then you can define methods that deal with blocks, R> which you can't with define_method: This is because you use strange name like #foo and "bar"and ruby don't like it :-) uln% cat b.rb #!./ruby cl = Class.new do define_method(:alpha) do |&block| block["beta"] end end cl.new.alpha {|x| p x} uln% uln% b.rb "beta" uln% Guy Decoux