From: gotoken@... (GOTO Kentaro) Date: 2001-03-13T03:01:35+09:00 Subject: [ruby-talk:12518] Re: Math package In message "[ruby-talk:12513] Re: Math package" on 01/03/13, Yukihiro Matsumoto writes: >|>I don't get the point. Math is too broad word for the libm functions? >| >|Yes, it is. And that would show an example of hierarchy in a module. > >I still don't get the point of your second statement. Having both >Math::sin() and Math::Libm::sin() would not be a good example. >I think you have something untold in your mind. I'm sorry for too short words. At first, I would propose replacing Math::sin() with Math::Libm::sin(). But this brings serious backward incompatibility. Then, I thought (unwillingly) not only replacing but including in to Math. However, it is not what I want as you said. Another option I hit on is rename Math to Num. Anyway, something incompatible can't be avoid... -- Gotoken