From: Douglas Livingstone Date: 2005-01-05T00:27:46+09:00 Subject: Re: Composition or Module > > def to_s > > return sprintf('%s=%s', self.class, @value) > > end > Module seems more natural to me, but maybe "Representable" would be a > better name. Or something like "Pretty_s" because to_s exists anyway. Douglas