From: matz@... (Yukihiro Matsumoto) Date: 2001-03-12T08:01:07+09:00 Subject: [ruby-talk:12432] Re: Haskell goodies, RCR and challenge Hi, In message "[ruby-talk:12374] Re: Haskell goodies, RCR and challenge" on 01/03/10, Yukihiro Matsumoto writes: || (0..4).to_a.partition {|e| e%2 == 0} # => [[0,2,4], [1,3]] | |I like this function. Although it's mere combination of "select" and |"reject". But I don't prefer the word "partition" for the |functionality. The method name should be verb, and preferably end with "ct" to rhyme with other method names. e.g. "bisect"? matz.