From: "Williams, Chris" Date: 2004-12-15T03:16:08+09:00 Subject: Apache2, FastCGI and Rails on Windows ------_=_NextPart_001_01C4E208.F2C1C7C1 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable I've been running around in circles trying to enable FastCGI on my rails install. I've modified my http.conf to load the fastcgi module and add it as the handler for .fcgi I've modified my .htaccess to redirect to dispatch.fcgi, and that is working.=20 What happens is that Rails throws back the 500 page with an error, and Apache's error log show's the following: [Tue Dec 14 12:56:09 2004] [warn] FastCGI: (dynamic) server "C:/epc/blog/public/dispatch.fcgi" started (pid 1636) [Tue Dec 14 12:56:11 2004] [error] [client 127.0.0.1] (OS 109)The pipe has been ended. : FastCGI: comm with server "C:/epc/blog/public/dispatch.fcgi" aborted: GetOverlappedResult() failed [Tue Dec 14 12:56:11 2004] [warn] FastCGI: (dynamic) server "C:/epc/blog/public/dispatch.fcgi" (pid 1636) terminated with exit with status '1' [Tue Dec 14 12:56:11 2004] [error] [client 127.0.0.1] FastCGI: incomplete headers (0 bytes) received from server "C:/epc/blog/public/dispatch.fcgi" [Tue Dec 14 12:56:11 2004] [error] [client 127.0.0.1] File does not exist: C:/Program Files/Apache Group/Apache2/htdocs/favicon.ico [Tue Dec 14 12:56:14 2004] [warn] FastCGI: (dynamic) server "C:/epc/blog/public/dispatch.fcgi" restarted (pid 2472) [Tue Dec 14 12:56:16 2004] [warn] FastCGI: (dynamic) server "C:/epc/blog/public/dispatch.fcgi" (pid 2472) terminated with exit with status '1' [Tue Dec 14 12:56:19 2004] [warn] FastCGI: (dynamic) server "C:/epc/blog/public/dispatch.fcgi" restarted (pid 3652) [Tue Dec 14 12:56:20 2004] [warn] FastCGI: (dynamic) server "C:/epc/blog/public/dispatch.fcgi" (pid 3652) terminated with exit with status '1' [Tue Dec 14 12:56:24 2004] [warn] FastCGI: (dynamic) server "C:/epc/blog/public/dispatch.fcgi" restarted (pid 2120) [Tue Dec 14 12:56:26 2004] [warn] FastCGI: (dynamic) server "C:/epc/blog/public/dispatch.fcgi" (pid 2120) terminated with exit with status '1' [Tue Dec 14 12:56:26 2004] [warn] FastCGI: (dynamic) server "C:/epc/blog/public/dispatch.fcgi" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds It seems to be unable to communicate over the default pipe. Has anyone managed to get this working? What am I doing wrong? Thanks, Chris ------_=_NextPart_001_01C4E208.F2C1C7C1--