From: "trans. (T. Onoma)" Date: 2004-12-10T07:13:00+09:00 Subject: Re: String#split behaves odd On Thursday 09 December 2004 04:39 pm, Ibraheem Umaru-Mohammed wrote: | +++ trans. (T. Onoma) [ruby-talk] [10/12/04 05:24 +0900]: | > class Array | > def compact_on(n=nil) | > if n | > delete(n) | > else | > compact | > end | > self | > end | > end | > | > Better name? Or better solution? | | Array#reject | | perhaps? | | --ibz. Except that takes a block. Hmm, could change reject to also accept a parameter. Of course we could have compact take a parameter too. Which of the three is the best way to go? T.