From: "trans. (T. Onoma)" Date: 2004-12-08T05:43:42+09:00 Subject: Re: Idiom for creating hash from two arrays On Tuesday 07 December 2004 12:42 pm, Jonathan Paisley wrote: | def Hash.from_pairs(keys,values) # or some better name |   h = {} |   keys.zip(values) do |k,v| |     h[k] = v |   end |   h | end zipnew ? T.