From: Florian Gross Date: 2004-11-18T03:33:15+09:00 Subject: Re: assert Wood, Jeff wrote: > It's a semantic thing, but you could also go with an #ensure name > But, I guess I have a question, why not just have a function that > switches asserts to either raise an exception or cause an IRB > session? that way you could KNOW your code isn't going to break into > IRB in it's production environment, unless you specifically ask it > to... Problem with using assert() for the method name is that test/unit already uses it for stating what a test ought to produce. It seems likely that you will have test/unit style assert()s and breakpoint style assert()s (which I'd like to call assumptions) in the same code base.