From: Paul Brannan Date: 2004-11-16T23:12:46+09:00 Subject: Re: Kernel#singleton_class On Tue, Nov 16, 2004 at 03:18:32AM +0900, Yukihiro Matsumoto wrote: > In message "Re: Kernel#singleton_class" > on Tue, 16 Nov 2004 02:54:13 +0900, "trans. (T. Onoma)" writes: > > || I'd call them singleton classes. Any objection? > > |Yes, cause of singleton pattern. > > Hmm, any other alternative? I think I've heard them called "metaclasses"; is that the same thing or just a bad application of the word metaclass? I think in an ideal world (one which revolves around me) I would continue to call them singleton classes, and completely eradicate the singleton antipattern from the standard library. Paul