From: "trans. (T. Onoma)" Date: 2004-11-16T03:38:11+09:00 Subject: Re: Kernel#singleton_class On Monday 15 November 2004 01:18 pm, Yukihiro Matsumoto wrote: | Hi, | | In message "Re: Kernel#singleton_class" | | on Tue, 16 Nov 2004 02:54:13 +0900, "trans. (T. Onoma)" writes: | || I'd call them singleton classes. Any objection? | | | |Yes, cause of singleton pattern. | | Hmm, any other alternative? | | I don't prefer the terms "instance class" and "object class", just | because it's meaningless. Classes are naturally corresponding to | objects (or instances) in OOP. Besides, the word singleton used from | Lisp era, way older than design patterns, IIRC. Interesting. I didn't know that. I wouldn't normally object but I've seen discussion confusion over this more times than I can count. As for something meaningful, the word 'special', as in specialized, again comes to mind. Merriam-Webster Entry Entry Word: special Function: adjective Text: 1 of or relating to one thing or class -T.