From: Yukihiro Matsumoto Date: 2004-11-16T03:18:32+09:00 Subject: Re: Kernel#singleton_class Hi, In message "Re: Kernel#singleton_class" on Tue, 16 Nov 2004 02:54:13 +0900, "trans. (T. Onoma)" writes: || I'd call them singleton classes. Any objection? |Yes, cause of singleton pattern. Hmm, any other alternative? I don't prefer the terms "instance class" and "object class", just because it's meaningless. Classes are naturally corresponding to objects (or instances) in OOP. Besides, the word singleton used from Lisp era, way older than design patterns, IIRC. matz.