From: Gavin Sinclair Date: 2004-11-13T23:44:31+09:00 Subject: Re: assert On Sunday, November 14, 2004, 1:18:24 AM, Florian wrote: > Gavin Sinclair wrote: >>>I have thought about changing the name to "assume" so it can be included >>>in dev-utils, but I'm not sure if that name is better. >> Maybe >> >> breakpoint :unless => 'x + y == 10' >> >> ? > I think that would be way too much magic. I'd expect the method to just > take a block. Why a block? The breakpoint code uses Binding.of_caller anyway, so a block is not needed for evaluation. I don't see any other reason, technical or stylistic, why a block should be preferred. I suppose we might as well dispose of the symbolic argument and just do this: breakpoint_unless 'x + y == 10' Can you expand on the "too much magic"? Gavin