From: matz@... (Yukihiro Matsumoto) Date: 2001-03-05T18:04:37+09:00 Subject: [ruby-talk:12005] Re: How do I reach members from a Proc? Hi, In message "[ruby-talk:12003] Re: How do I reach members from a Proc?" on 01/03/05, "Conrad Schneiker" writes: |# Can I go for the method name with the most underscores? |# |# obj#adopt_block_and_call |# |# Although I'm not thrilled with the 'block_and_call' part, I quite |# like 'adopt' as a word for describing the behavior of instance_eval. | |I'm inclined to agree. However, given that instance_eval already |exists (and will continue to IIUC), how about something more like |'block_eval_and_call' for PMC (principle of mnemonic consistency) and |POLS (principle of least shock, err, surprise). Thinking of what it does (switch the value of self, then evaluate block, nothing more), these names are too much, I feel.. matz.