From: "David A. Black" Date: 2004-11-12T10:13:32+09:00 Subject: Re: non-nil, etc. (was Re: true? & false?) Hi -- On Fri, 12 Nov 2004, Hal Fulton wrote: > Joel VanderWerf wrote: > > > > Why not just define #empty? for Fixum, File, NilClass, and Object, and > > then define nonempty? instead of (argh, can't... make... self... type... > > this...) nnull? ? > > Yes, nnull? is a pretty ugly name, isn't it? But I dislike long names > such as non_null, not_null, non_empty, aint_null, etc. How about ull? :-) David -- David A. Black dblack@wobblini.net