From: "trans. (T. Onoma)" Date: 2004-10-01T20:40:12+09:00 Subject: Re: AClass() vs. AClass[] constuctors (was Best name for "this method") This might be of interest: Class [] Method Kernel () Method Array x x Hash x Struct::Tms x Dir x Float x Integer x String x Binding x* Proc x* * methods are not capitalized So why not make this more consistant, clean up some kernel space, and give capitalized methods some legs, with e.g. class String def self.()(x) x.to_s end end T.