From: "trans. (T. Onoma)" Date: 2004-10-01T20:14:48+09:00 Subject: Re: AClass() vs. AClass[] constuctors (was Best name for "this method") On Thursday 30 September 2004 09:00 am, Robert Klemme wrote: > Just a side note: if I wanted specialized constructors, I'd use class > instance methods like this: > > class Foo > def initialize(...) > ... > end > > def self.newEmpty() > allocate > end > > def self.newBla() > x = allocate > x.foo = "bar" > x > end > ... > end > > But in fact I haven't felt the need for this so far. True 'nuff, and I have done this myself a few times. Nonetheless a number of [] constructors exist. T.