From: Robert Klemme Date: 2004-09-30T22:00:02+09:00 Subject: Re: AClass() vs. AClass[] constuctors (was Best name for "this method") "trans. (T. Onoma)" schrieb im Newsbeitrag news:200409300747.00023.transami@runbox.com... > So back to point. To me the Class[] constructor notation is poor, and Class() > is much preferable. Note, I am not advocating a replacement for .new(), as I > think some have taken it. Nor am I suggesting filling-up Kernel space. Fine. :-) > Nor > that my example method_missing means is the proper approach. Rather, it would > simply be a special class constructor that one could define in the classes, > and would default to Class.new. Just a side note: if I wanted specialized constructors, I'd use class instance methods like this: class Foo def initialize(...) ... end def self.newEmpty() allocate end def self.newBla() x = allocate x.foo = "bar" x end ... end But in fact I haven't felt the need for this so far. Regards robert