From: Robert Klemme Date: 2004-09-30T16:25:14+09:00 Subject: Re: AClass() vs. AClass[] constuctors (was Best name for "this method") "David A. Black" schrieb im Newsbeitrag news:Pine.LNX.4.44.0409291852470.2901-100000@wobblini... > I'm not sure about a use case; it just doesn't fit the model. Classes > and modules have constants; other objects, as far as I know, don't. > Having this kind of transparent delegation makes it seem like they do, > which is misleading. > > I also wouldn't want non-classes to start having superclasses, class > methods, etc., just because they have a class. And if I were a Class, > I wouldn't want all my instances acting like me; I'm an object in my > own right :-) +1 robert