From: James Edward Gray II Date: 2004-09-29T09:41:48+09:00 Subject: Re: Best name for "this method" ? On Sep 28, 2004, at 6:57 PM, trans. (T. Onoma) wrote: > Why would I want to write a constructor like Hash[], when it could > just as well be written Hash()? And in fact I don't --I cannot think > of a single time that I have > used the later notation. Why? *Not* because it isn't useful, but > rather b/c > it obfuscates my code b/c is looks like an Array or Hash lookup, and > not like > calling a constructor method. I'm not a fan of Class(), but I have to agree with the above complaint. Why Hash[] makes a new Hash is beyond me. I'm not a fan of that interface. James Edward Gray II