From: "David A. Black" Date: 2004-09-28T21:12:40+09:00 Subject: Re: Best name for "this method" ? Hi -- On Tue, 28 Sep 2004, trans. (T. Onoma) wrote: > h = { a: 1, b: 2 } > h.a #=> 1 > h.b #=> 2 > > That would be sweet. And would make the above possible without a new class. I > know, method name clash is bad --and there's little one can do to get around > it. Perhaps alternate notation? > > h:a > h:b What's wrong with h[:a] ? David -- David A. Black dblack@wobblini.net