From: Florian Gross Date: 2004-09-28T17:29:21+09:00 Subject: Re: Best name for "this method" ? trans. (T. Onoma) wrote: >>Binding.of_caller? Could you explain this more? I'm not sure to what you >>are referring. > Okay, I see. I did some research to understand. The problem I see with this is > that it might have too large an overhead --in effect creating a binding prior > to every method invocation. Is that so? On the other hand, I see no reason > for 'self' of caller not to be available. Why? As you can see from my trace_func implementation Ruby already knows how to fetch the binding on demand (via ruby_frame->prev) -- it just doesn't provide a way to do it from within Ruby. Regards, Florian Gross