From: Yukihiro Matsumoto Date: 2004-09-21T07:53:16+09:00 Subject: Re: Array#index block and rdetect Hi, In message "Re: Array#index block and rdetect" on Tue, 21 Sep 2004 01:23:07 +0900, "David A. Black" writes: |> This (numerical index) is what I thought when I designed |> each_with_index. So I vote for introducing a new name. | |I liked Tom's idea of "counter". That seems to be more what it is. Sorry for being noisy. Do you mean we should rename each_with_index to each_with_counter? In that case, do you have any estimation about compatibility? matz.