From: "trans. (T. Onoma)" Date: 2004-09-13T04:14:17+09:00 Subject: Re: Singleton method on object via define_method? On Sunday 12 September 2004 02:19 pm, Martin DeMello wrote: > "trans. (T. Onoma)" wrote: > > > Good! I'd just put it into class Object instead of module Kernel. > > > That's a more appropriate place IMHO. Also "metaclass" seems the wrong > > > term in this case, although I can see why you didn't want to use > > > "singleton_class"... > > > > Agreed. Better name? > > selfclass? That's better. Or maybe self_class. That could work. -- ( o _ // trans. / \ transami@runbox.com I don't give a damn for a man that can only spell a word one way. -Mark Twain