From: Martin DeMello Date: 2004-09-13T03:19:56+09:00 Subject: Re: Singleton method on object via define_method? "trans. (T. Onoma)" wrote: > > > Good! I'd just put it into class Object instead of module Kernel. That's > > a more appropriate place IMHO. Also "metaclass" seems the wrong term in > > this case, although I can see why you didn't want to use > > "singleton_class"... > > Agreed. Better name? selfclass? martin