From: "Guy N. Hurst" Date: 2001-02-20T01:26:14+09:00 Subject: [ruby-talk:11114] Re: Summary: RCR #U002 - proper new name fo r indexes Mike Wilson wrote: > ... > Just wanted to jump in and give 3 cents worth. This is an argument that > could go on endlessly. It's based primarly on personal preference and isn't > really worth continuing much longer (IMHO). I'd like to suggest that matz > has enough offerings on the table and propose that we should discontinue > this thread in favor of matz making the final decision so that we continue > with other matters. As Dave said on #ruby-lang (paraphrased) "matz has done > a great job with naming. If it were me, and I was programming in Japanese > you'd be using Array#goldfish". > Hey, that is a great idea! As my four-year old likes to play "goldfish" (his pronunciation for the card game "Go Fish"), I suggest it for this method of selecting elements, altering it slightly: Array#go_fish, Hash#go_fish ["seven of hearts", "jack of spades", "two of clubs"].go_fish(2,0) Guy N. Hurst -- HurstLinks Web Development http://www.hurstlinks.com/ Norfolk, VA 23510 (757)623-9688 FAX 623-0433 PHP/MySQL - Ruby/Perl - HTML/Javascript