From: Mike Wilson Date: 2001-02-20T01:09:30+09:00 Subject: [ruby-talk:11112] Re: Summary: RCR #U002 - proper new name fo r indexes >From: Robert Feldt >Reply-To: ruby-talk@ruby-lang.org >To: ruby-talk@ruby-lang.org (ruby-talk ML) >Subject: [ruby-talk:11105] Re: Summary: RCR #U002 - proper new name fo r >indexes >Date: Tue, 20 Feb 2001 00:17:42 +0900 > >On Tue, 20 Feb 2001, Jean Michel wrote: > > > >> > (a) Hash#values, Array#values > > >> > (b) Hash#values_for, Array#values_for > > >> > (g) Hash#selections, Array#selections > > >> > (h) Hash#collect_indexes, Array#collect_indexes > > >> > (f) Hash#subset, Array#subset > > >but I'd vote for Hash#elements_at/Array#elements_at or >Hash#elements/Array#elements. > Just wanted to jump in and give 3 cents worth. This is an argument that could go on endlessly. It's based primarly on personal preference and isn't really worth continuing much longer (IMHO). I'd like to suggest that matz has enough offerings on the table and propose that we should discontinue this thread in favor of matz making the final decision so that we continue with other matters. As Dave said on #ruby-lang (paraphrased) "matz has done a great job with naming. If it were me, and I was programming in Japanese you'd be using Array#goldfish". Mike Wilson Unix Administrator http://ruby.weblogs.com _________________________________________________________________ Get your FREE download of MSN Explorer at http://explorer.msn.com