From: "Aleksi Niemelä" Date: 2001-02-19T21:49:03+09:00 Subject: [ruby-talk:11094] Re: Summary: RCR #U002 - proper new name fo r indexes > On Mon, 19 Feb 2001, Yukihiro Matsumoto wrote: > > > So candidates are: > > > > (a) Hash#values, Array#values > > (b) Hash#values_for, Array#values_for > > (c) Hash#values_for, Array#values_at > > (d) Hash#at, Array#at > > (e) Hash#values, Array#elements > > (f) Hash#subset, Array#subset > > (g) Hash#selections, Array#selections > > (h) Hash#collect_indexes, Array#collect_indexes > > > > Did I miss any propsal from you guys? > David Alan Black added: > (i) Hash#values_for, Array#elements_at My vote(s) go for choice i, or if in the end game it's considered too long, I'd revert to (j) Hash#values, Array#elements - Aleksi