From: matz@... (Yukihiro Matsumoto) Date: 2001-02-19T16:32:35+09:00 Subject: [ruby-talk:11087] Summary: RCR #U002 - proper new name for indexes Hi, In message "[ruby-talk:11066] Re: RubyChangeRequest #U002" on 01/02/19, Paul Pladijs writes: |The explanation of Hash#indexes at |http://www.rubycentral.com/ref/ref_c_hash.html#indexes |says: | | Returns a new array consisting of values for the given key(s). | Will insert the default value for keys that are not found. | |So Hash#values_for is probably the best descriptive name. So candidates are: (a) Hash#values, Array#values (b) Hash#values_for, Array#values_for (c) Hash#values_for, Array#values_at (d) Hash#at, Array#at (e) Hash#values, Array#elements (f) Hash#subset, Array#subset (g) Hash#selections, Array#selections (h) Hash#collect_indexes, Array#collect_indexes Did I miss any propsal from you guys? matz.