From: Kevin Smith Date: 2001-02-16T13:38:08+09:00 Subject: [ruby-talk:10951] Re: RubyChangeRequest #U002: new proper nameforHash#indexes, Array#indexes matz@zetabits.com wrote: > on 01/02/16, Kevin Smith writes: >|Extending Hash#values to accept a list of keys >|still seems best to me. > >Hash#values sounds good to me too. >How about Array? Array#values? Array#values is fine with me. It's a bit odd that a.values( ) would return...a copy of the selfsame array. Oh, well. >And how do you think about extending Hash#keys too? >Or extending Hash#index/Array#index to accept multiple arguments? If Array#index and Hash#index accept multiple arguments, then they should be called #indexes...whoops, that's what started all this. Um, I guess extending Hash#keys makes sense, although I'm not sure how critical that feature is. It sure would be nice to have a corresponding method for Array, but I can't think of a good name. Kevin