From: Conrad Schneiker Date: 2001-02-16T10:14:30+09:00 Subject: [ruby-talk:10939] Re: RubyChangeRequest #U002: new proper namefor Hash#indexes, Array#indexes Matz wrote: # on 01/02/16, Kevin Smith writes: # # |>> Array#elements? Hash#values? # | # |Extending Hash#values to accept a list of keys # |still seems best to me. # # Hash#values sounds good to me too. # How about Array? Array#values? FWIW, I prefer 'values' for its consistency with general comp. sci. and math terminology. Besides, isn't Ruby a values-oriented language, expression-wise? :-) # And how do you think about extending Hash#keys too? Or extending # Hash#index/Array#index to accept multiple arguments? FWIW, I would like to see something like that. LISP: The lamda machine language of AI. Ruby: The natural OO language of AI. Conrad Schneiker (This note is unofficial and subject to improvement without notice.)