From: Conrad Schneiker Date: 2001-02-16T07:01:44+09:00 Subject: [ruby-talk:10934] Re: RubyChangeRequest #U002: new proper name for Hash#indexes, Array#indexes Dave Thomas wrote: # matz@zetabits.com (Yukihiro Matsumoto) writes: # # > Possible. The key is here. # > # > |a.at(0) -> 1 # maybe change to [1]? # > # > For consistency, at(0) might be better to return an array, but it's # > incompatibility, which I don't want to incorporate. # > # > Array#elements? Hash#values? # # I _think_ I'd prefer #elements_at and #values_at, but I'm not sure. I'd vote for that--I think you want to both retain but differentiate 'at' for reasons of "backwards consistency". # However, I _do_ like the use of plural words to suggest that # multiple values are returned. That's a consistent hint that is very # useful. 100% agreement. Conrad Schneiker (This note is unofficial and subject to improvement without notice.)