From: matz@... (Yukihiro Matsumoto) Date: 2001-02-16T02:57:23+09:00 Subject: [ruby-talk:10918] Re: RubyChangeRequest #U002: new proper namefor Hash#indexes, Array#indexes Hi, In message "[ruby-talk:10908] Re: RubyChangeRequest #U002: new proper namefor Hash#indexes, Array#indexes" on 01/02/16, Kevin Smith writes: |>> Array#elements? Hash#values? | |Extending Hash#values to accept a list of keys |still seems best to me. Hash#values sounds good to me too. How about Array? Array#values? And how do you think about extending Hash#keys too? Or extending Hash#index/Array#index to accept multiple arguments? matz.