From: Kevin Smith Date: 2001-02-16T01:23:32+09:00 Subject: [ruby-talk:10907] Re: RubyChangeRequest #U002: new proper namefor Hash#indexes, Array#indexes matz@zetabits.com wrote: >|a.at(0) -> 1 # maybe change to [1]? > >For consistency, at(0) might be better to return an array, but it's >incompatibility, which I don't want to incorporate. Thanks. at(0) returns an array element in every language I've seen, so I think it's important for it not to return an array. Kevin