From: Mathieu Bouchard Date: 2001-02-15T19:46:55+09:00 Subject: [ruby-talk:10894] Re: RubyChangeRequest #U002: new proper name for Hash#indexes, Array#indexes On Thu, 15 Feb 2001, Dave Thomas wrote: > matz@zetabits.com (Yukihiro Matsumoto) writes: > > Array#elements? Hash#values? > I _think_ I'd prefer #elements_at and #values_at, but I'm not sure. > However, I _do_ like the use of plural words to suggest that multiple > values are returned. That's a consistent hint that is very useful. Of all the solutions proposed, I vote for #values_at, with same semantics as current #indices. matju