From: matz@... (Yukihiro Matsumoto) Date: 2001-02-14T15:55:05+09:00 Subject: [ruby-talk:10830] RubyChangeRequest #U002: new proper name for Hash#indexes, Array#indexes Hi, I have to admint `indexes' is not good name, since its behavior (returning values corresponded to keys/indexes) not consistent with one of `index' (returning key/index of value). Let's face it. I decided to declare them obsolete and give proper new names in the future (1.7 and forth coming 1.8/2.0). Do you have any idea of good name for them? I'm not going to remove them, just give warning if you use them. matz.