From: matz@... (Yukihiro Matsumoto) Date: 2004-08-03T14:26:34+09:00 Subject: Re: Request for two methods in Array class Hi, In message "Request for two methods in Array class" on 04/08/03, Mike Hall writes: |1. A new method, Array.combine (needs a better name for general use). | It takes entries from two (or many) arrays and combines them. | (like a combination of Array.zip, fetch, and map) Sounds nice. But I'm not sure "combine" is a proper name for the method. We need more discussion, for example: * the best name for the behavior. * whether it takes only one argument or any number of arguments. * whether "multiplication" should be the default. |2. A block initializer for Array.new, like that for Hash.new. | Good for self-initializing a table of recurrence relations. Array.new already takes a block, with little bit different behavior than what you've describe. In addition, | a = Array.new() {|self, i| 2*self[i-1] - self[i-2]} I assume this accesses self[-1] and self[-2] during the array initialization, which seem no good. Perhaps there should be better way to express what you want. matz.