From: Hal Fulton Date: 2004-07-21T16:25:06+09:00 Subject: Re: sysread and buffered I/O Tanaka Akira wrote: > I proposed stdio friendly sysread like method: readpartial. > [ruby-dev:23247] [ruby-talk:96220] Very interesting, I did not notice that. Thank you. > However it is not incorporated into ruby just because the name is not > good enough. Currently I think readchunk is better, though. I am not sure I like readchunk. I think I prefer an underscore at least. Other ideas might be: read_partial # looks better with underscore? read_part read_any read_all (?) read_waiting (?) read_avail # meaning "available" read_bytes readbytes # looks ok without underscore? > The new class SysIO is not required. > I think matz will accept stdio-less implementation for IO. OK, I see. The code is already written? Are we just seeking a name? Hal