From: evanm@... Date: 2004-06-24T20:22:43+09:00 Subject: Re: Cleaning up IO#popen On Thu, Jun 24, 2004 at 12:04:45PM +0900, nobu.nokada@softhome.net wrote: > I admit there will be better ways much. But I'd like to > introduce a new class for child process rather than popen3. Sure. My main concern is looking to the functions in the base classes and stdlib, and seeing inconsistant argument handling. I agree that a lot of this should live in a new class, but where possible I'd try to standardize the interface, even between IO and some new class. > Single pipe pair cannot be used for bidirectional, and > fork_open doesn't feel a good name for me. Pardon me, I meant to say that it leaves both ends open. Perhaps fork_read or fork_write? I don't like the name either, but it's all I could think of.