From: Warren Brown Date: 2004-06-15T07:58:23+09:00 Subject: Re: undefine Tony, > while() > { > # date parsing code was here > @diff=Delta_DHMS(@binkdate,@today) if /(\[\d+\])/; > print $trimmed $_ if $diff[0] < $ARGV[1] && defined(@diff); > next if defined(@diff); > print $trimmed $_ if ! /(\[\d+\])/; > undef(@diff); > } It looks like this could be simplified to: while() { # date parsing code was here if /(\[\d+\])/ then diff = Delta_DHMS(@binkdate,@today); print $trimmed $_ if diff[0] < $ARGV[1]; next; else print $trimmed $_; end } I guess I still don't see the need to define an instance variable and then undefined it. BTW, why do all of your posts have a subject line of "undefine" on the mailing list? - Warren Brown