From: Ryan Paul Date: 2004-06-13T03:58:37+09:00 Subject: Re: Appropriate use of camelCase > I would vote for extending the end and enforce a "end class", "end > def", or "end module". This would make the syntax much more readable > and this is what is most important in the long term. Part of what makes ruby powerful is the fact that it doesnt sacrifice power and brevity to increase readability. Ruby is downright unintuitive in some places, with extremely rewarding consequences. For instance, compare ruby blocks to python list comprehensions: lst.reject {|x| not x.upcase.include? n.upcase } vs. [x for x in lst if n.upper in x.upper] Ruby's looks cryptic by comparison. (I particularly dislike ruby's lack of an 'in' operator - adding that would be a MUCH better way to increase readability) Ruby blocks may not be as intuitive, but they DEFINITELY stack better. for instance: ["*.rar.*", "*.r[0-9][0-9].*"].each {|fn| Dir[$prefix+fn].collect {|x| x.gsub(/\.\d+[\d.-]*$/,"")}.uniq.each {|x| `cat #{sesc x}.* > #{sesc x}`} } It would probably require three times as much code to do that in python, particularly the regular expressions. Inline regular expressions definitely dont do nice things for readability, but they are incredibly powerful. That code sample, btw, is part of a script I wrote to concatenate pieces of incomplete rar files downloaded from a.b.startrek with BNR. Its part of a script I use regularly, and I initially wrote it that way, I didnt intentionally obfuscate it. I initially tried writing it in python and got frustrated with the syntactic hoops I had to jump through. -- SegPhault