From: Thomas Fini Hansen Date: 2004-06-07T04:14:58+09:00 Subject: Re: Reply wasn't posted; will test new post On Mon, Jun 07, 2004 at 02:53:39AM +0900, daz wrote: > > Thomas Fini Hansen wrote: > > Austin Ziegler wrote: > > > > > (References is a News header ONLY). > > > > Wrong. > > > > RFC 2822 - Internet Message Format: > > > > > > RFC 2822 is a not a standard, yet. > > >From http://www.ietf.org/iesg/1rfc_index.txt (long) > > """ > 2822 Internet Message Format. P. Resnick, Ed.. April 2001. (Format: > TXT=110695 bytes) (Obsoletes RFC0822) (Status: PROPOSED STANDARD) > """ > > > A References: header is accepted by: > RFC822: Standard for ARPA Internet Text Messages August 13, 1982 # 4.6.3. REFERENCES # # The contents of this field identify other correspondence # which this message references. Note that if message identif- # iers are used, they must use the msg-id specification format. The header is mentioned in a >20 year old spec, does contradict the claim that it's a news header only, doesn't it? Yes, neither RFC says that it is required, but the same goes for In-Reply-To. Both treat them pretty much equal, so what anyone has to say about References, goes for In-Reply-To as well. > and > RFC850: Standard for Interchange of USENET Messages > > "... the rule is adopted that all USENET news articles > must be formatted as valid ARPANET mail messages, > according to the ARPANET standard RFC 822." > > Our missing ML-> NG messages, after conversion from mail to news by rubygate, > are valid to RFC822/RFC850 standard regardless of the MUA used for posting. That's reverse logic, it only claims that all news messages is valid mails, not that all mail is valid news. And RFC850 in section 2.1.6 tells us that the References header is *required* when the Subject header starts with 'Re: '. There's no such requirement for mail messagees, or Outlook would be in *violation* of the specs, not just being annoying. But of course, all of this is just good practice, as no spec requires either References nor In-Reply-To to be used. -- Thomas beast@system-tnt.dk