From: Warren Brown Date: 2004-05-27T03:33:05+09:00 Subject: Re: [RCR] Numeric#of > The only possible change I would make would be > in the name. Integer#to_enum > This seems to follow and the other "to_xxx" > named methods. Or to be even more precise, we could add Integer#to_range, since that is exactly what Integer#to_enum would be doing. Of course, "5.to_range.map { ... }" isn't really that far away from "(0...5).map { ... }", so I'm unconvinced that the language really needs the new construct. - Warren Brown