From: gotoken@... (GOTO Kentaro) Date: 1998-08-17T20:33:15+09:00 Subject: [ruby-list:9175] Re: Matrix#to_i [Re: irb -m] ごとけんです In message "[ruby-list:9174] Re: Matrix#to_i [Re: irb -m]" on 98/08/17, Sinichiro Dezawa writes: >出沢です >gotoken> Numeric#to_f と Numeric#to_i は削るべきだと思います。 > >これは、Numeric 自身の話でしょうか、Numeric をsuperに持つ >もの全てに、でしょうか。後者だとしたら勘弁して欲しいです。 もちろん前者の意味です。ドキュメントにはあるので、 抽象クラス特有な仕様としてのメソッドと思っていたのですが 実際は定義されておらず、まつもとさんも無いつもりのようですし、 意味のない発言でした。ごめんなさい。 言いたかったコトは、kind_of?(Numeric) #=> true でも to_i や to_f を持つことを必須にすべきではないということです。 ところで >もっとも、 float.to_f がないのですね。、、、、 え? Float#to_f ならあるのでは? 少なくとも 1.1c2 にはあります。 -- gotoken