From: Sinichiro Dezawa Date: 1998-08-17T20:17:13+09:00 Subject: [ruby-list:9174] Re: Matrix#to_i [Re: irb -m] 出沢です gotoken> 結論から言うと gotoken> Numeric#to_f と Numeric#to_i は削るべきだと思います。 これは、Numeric 自身の話でしょうか、Numeric をsuperに持つ もの全てに、でしょうか。後者だとしたら勘弁して欲しいです。 count[key] = count[key].to_i + 1 とか、 sum[key] = sum[key].to_f + value とかを sum[key]の既出の有無によらず書けると嬉しいのです。 もっとも、 float.to_f がないのですね。、、、、