From: gotoken@... (GOTO Kentaro) Date: 1998-08-14T21:36:46+09:00 Subject: [ruby-list:9110] Re: irb -m ごとけんです In message "[ruby-list:9109] Re: irb -m" on 98/08/14, Yukihiro Matsumoto writes: >まつもと ゆきひろです >最近イテレータブロックという単語は使わないように >しているので(あちこち残ってますが),その辺を修正した上で取り >込みます.コメントは歓迎です. なんでもかんでもイテレータブロックと言わないように なったのは好ましく思いますが、まさにイテレータとして 呼ばれたときはそう呼んだ方が良いようにも感じます。 >で,以前にも話が出たような気がするのですが,行列に対してto_i >やto_fを行った時に実数や整数ではなく,それらの配列を返すって >のはまずいように思います. 同感です。 Matrix の to_s 以外の to_ は map_to_ とか to_mof (matrix of Float) とでもしした方が良いと 思います。 ところで対角化や各種分解や固有値が matrix.rb や 拡張モジュールで実装される予定はありますか? -- gotoken