From: matz@... (Yukihiro Matsumoto) Date: 1998-02-20T16:21:48+09:00 Subject: [ruby-list:6574] Re: Counter class [Re: i++ ] まつもと ゆきひろです In message "[ruby-list:6572] Re: Counter class [Re: i++ ]" on 98/02/20, Keiju ISHITSUKA writes: |けいじゅ@日本ラショナルソフトウェアです. |ここは以下ので良いと思います. | | def coerce(other) | return other, @obj | end | |やるべきことは相手を変換することではなくて, 自分が計算できるように変換 |することですから. これは多分, def coerce(other) @obj.coerce(other) end が正解ではないでしょうか? ということはcoerceの定義そのもの が要らないと言うことですね.